搜索
首页 教育/科学 职业教育 职业培训

WordPress现在存在漏洞吗?

WordPress现在存在漏洞吗?

全部回答

2017-08-04

44 0

    WordPress是一款免费的论坛Blog系统。 WordPress的WassUp插件存在输入验证漏洞,远程攻击者可能利用此漏洞执行SQL注入攻击。 WordPress的WassUp插件中spy。
  php文件没有正确地验证对to_date参数的输入: # if (isset($_GET['to_date'])) $to_date = htmlentities(strip_tags($_GET['to_date'])); # 。
    。。。。。。。。。。 # spyview($from_date,$to_date,$rows); # # -In main。php # # function spyview ($from_date="",$to_date="",$rows="999") { # 。
    。。。。。。。。。。
     # $qryC = $wpdb->get_results("SELECT id, wassup_id, max(timestamp) as max_timestamp, ip, hostname, searchengine, # urlrequested, agent, referrer, spider, username, comment_author FROM $table_name WHERE timestamp BETWEEN $from_date AND # $to_date GROUP BY id ORDER BY max_timestamp DESC"); 这允许远程攻击者通过注入任意SQL代码控制SQL查询。

类似问题换一批

热度TOP

相关推荐
加载中...

热点搜索 换一换

教育/科学
职业培训
出国/留学
院校信息
人文学科
职业教育
升学入学
理工学科
外语学习
学习帮助
K12
职业教育
职业培训
远程教育
会计资格考试
司法考试
自考
公务员考试
职业培训
职业培训
举报
举报原因(必选):
取消确定举报